Bienvenue

Découvrir DOSBox avec D-Fend

Guide simplifié - Version 1.3b du 19/02/2006

- La Clinique des Jeux Vidéos -

- Une publication du réseau Abandonware France -

Avant de commencer nous tenions tout d’abord à vous remercier d’avoir téléchargé ce guide d’utilisation. Nous espérons que la lecture de ses pages vous permettra de mieux comprendre, et donc mieux maîtriser, les bases de cette fantastique machine virtuelle qu’est DOSBox.

Enfin il nous semblait nécessaire de préciser que ce guide d’utilisation se destine avant tout aux personnes qui ne possèdent pas nécessairement des connaissances sur le DOS® et/ou DOSBox. Les utilisateurs peut-être plus expérimentés ou désireux d'aller plus loin sont invités à se reporter aux guides d’utilisation intitulés Débuter avec DOSBox et Utilisation avancée de DOSBox.

Nous vous souhaitons à tous et à toutes une agréable lecture.

L’équipe du réseau Abandonware France

Les autres guides disponibles : Utilisation avancée de VDMSound.


Avant-propos

Introduction

L'évolution connue par le matériel informatique et les systèmes d'exploitation rend aujourd'hui de plus en plus difficile l'utilisation des jeux DOS® : c'est pourquoi des applications telles que DOSBox ont été développées.

DOSBox permet d'émuler une machine d'ancienne génération utilisant un système d'exploitation MS-DOS® et désignée sous l'appellation de machine virtuelle, par opposition à une machine réelle. Il devient alors possible de faire fonctionner des jeux DOS® sur des machines et des systèmes d'exploitation récents.

D-Fend est une application dont le rôle est de faciliter l'utilisation de DOSBox en fournissant une interface graphique ergonomique.

Principes

D-Fend repose sur une gestion de profils pour permettre la configuration et l’exécution de jeux DOS®. Un profil correspond en fait à une configuration donnée de DOSBox.

Chaque jeu nécessite la création d'un profil qui lui est propre, cependant un profil peut être applicable à plusieurs jeux : c'est pourquoi D-Fend vous permet d'automatiser leur création à partir de modèles. L'utilisation de modèles vous évite de recréer un profil de toute pièce pour chaque jeu, en vous basant pour cela sur un profil déjà existant.

Un profil se présente sous la forme d’une fenêtre composée de différents onglets. Chaque onglet fait référence à des fonctions dont DOSBox assure la prise en charge : gestion de l’affichage, répertoire dans lequel seront enregistrées les captures écrans effectuées, etc.

Compatibilité

Certains jeux peuvent ne pas fonctionner avec DOSBox, d’autres encore peuvent ne fonctionner que dans certaines conditions.

En outre si certains jeux peuvent être lancés avec DOSBox, ils peuvent malgré tout ne pas être jouables.

Reportez-vous au site officiel de DOSBox pour connaître la liste de compatibilité de la dernière version en cours.

Pour accéder au site officiel de DOSBox, cliquez ici.

Exigences matérielles requises

Les configurations suivantes ne sont fournies qu'à titre indicatif et concernent DOSBox :

  • Pour les jeux en mode réel : un processeur de type Pentium® II 400 au minimum,

  • Pour les jeux en mode protégé : un processeur de type Pentium® IV 1 Ghz au minimum.

Les performances obtenues peuvent varier en fonction des jeux, elles ne sauraient d’ailleurs être garanties : y compris sur des machines répondant aux exigences matérielles requises.

Pré-requis

Afin de faciliter la mise en pratique de ce guide, il est nécessaire que vous disposiez des applications suivantes :

  • DOSBox,

  • D-Fend,

  • Daemon Tools.


Installation

L'ensemble des exemples fournis dans ce guide de prise en main ont été réalisés sur la base des pré-requis suivants :

  • DOSBox sera installé dans le répertoire C:\DOSBox,

  • Les jeux DOS® seront placés dans le répertoire C:\Jeux_DOS,

  • D-Fend sera installé dans le répertoire C:\D-Fend.

Vous pouvez bien entendu utiliser des emplacements différents si vous le souhaitez, pensez cependant à adapter les chemins mentionnés en conséquence.

Installation de DOSBox

Une fois la dernière version téléchargée sur le site officiel de DOSBox, double-cliquez sur l'icône correspondante de manière à débuter la procédure d'installation.

Remarque : Pour une utilisation de DOSBox sous Windows®, téléchargez la version Win32 Installer.

Pour accéder au site officiel de DOSBox, cliquez ici.

Après avoir pris connaissance de la licence GNU et en avoir accepté les termes, cliquez sur le bouton I agree.

Le champ Select the folder to install DOSBox 0.xx Installer in : vous permet de définir dans quel répertoire sera installé DOSBox. Modifiez le chemin proposé par défaut pour C:\DOSBox.

Cliquez ensuite sur le bouton Install.

Une fois la procédure d'installation achevée, cliquez sur le bouton Close.

Il ne vous reste à présent qu'à mettre en place le répertoire dans lequel les jeux DOS® seront installés et exécutés. Ouvrez le disque C à partir du Poste de travail ou de l'Explorateur de Windows®, créez un nouveau répertoire puis renommez-le en Jeux_DOS.

Installation de D-Fend

Une fois la dernière version téléchargée sur le site D-Fend, double-cliquez sur l'icône correspondante de manière à débuter la procédure d'installation.

Pour accéder au site de D-Fend,cliquez ici.

Cliquez sur le bouton Next pour poursuivre l'installation.

Après avoir pris connaissance des conditions d'utilisation, cliquez sur le bouton Next.

Le champ Destination directory vous permet de définir dans quel répertoire sera installé D-Fend. Modifiez le chemin proposé par défaut pour le chemin C:\D-Fend. Il n'est pas nécessaire qu'il soit identique au chemin d'installation de DOSBox. Cliquez ensuite sur le bouton Next.

Une fois la procédure d'installation achevée, cliquez sur le bouton Finish.


Prise en main

Le lancement de D-Fend est relativement simple et peut se faire :

  • Depuis le menu Démarrer de Windows®,

  • En double-cliquant sur l'exécutable DFEND.EXE situé dans le répertoire racine de l'application (ici C:\D-Fend).

Lors du premier lancement, il vous sera demandé de spécifier l’emplacement de DOSBox. Cliquez sur le bouton OK de manière à accéder à une fenêtre de recherche permettant de parcourir l'arborescence de votre machine.

Sélectionnez le répertoire C:\DOSBox.

L'emplacement de DOSBox est enregistré dans le fichier D-FEND.INI situé dans le répertoire racine de D-Fend (ici C:\D-FEND) au niveau de la variable Location. Vous aurez donc tout loisir de le modifier ultérieurement si nécessaire.

Vous accédez enfin à la fenêtre principale de D-Fend.

A ce stade sachez que l’exploitation des jeux DOS® ne vous est pas encore possible.


Paramétrage

Pour faciliter l'utilisation des jeux DOS®, le paramétrage de D-Fend est nécessaire.

Configuration des options par défaut

Cliquez sur le menu Extra \ Configure defaults ou sur l'icône [image].

Cliquez sur l'onglet Mounting puis sur le bouton Add.

Paramétrez les options comme indiqué sur la capture suivante. Puis cliquez sur le bouton OK.

Le répertoire C:\Jeux_DOS sera monté en tant que disque dur C dans DOSBox, il sera donc considéré comme un disque dur à part entière, mais dans DOSBox uniquement. La présence d'un disque dur est en effet indispensable au bon fonctionnement de la grande majorité des jeux DOS®.

Cliquez sur l'onglet Général et modifiez les options comme indiqué sur la capture suivante.

Cliquez sur l'onglet Environment et modifiez les options comme indiqué sur la capture suivante.

Cliquez enfin sur le bouton OK pour valider la configuration par défaut.

Nous allons à présent définir trois modèles dont le rôle sera de faciliter la création de profils pour chaque jeu :

  • Le premier pour les jeux qui n'utilisent pas de CD-ROM,

  • Le second pour les jeux qui utilisent un véritable CD-ROM,

  • Le troisième pour les jeux dont le CD-ROM sera émulé à partir d'un fichier image (fichier au format ISO, BIN, CUE, NRG...).

Mise en place du premier modèle

Cliquez sur le menu Profile \ Add/Use template ou sur l'icône [image].

Cliquez ensuite sur le bouton Add.

Sélectionnez le menu Base on Default configuration.

Dans le champ Enter Template description saisissez le texte Pas de CD-ROM puis cliquez sur le bouton OK.

Cliquez sur le bouton OK de manière à valider le modèle en l'état.

Mise en place du second modèle

Dans la liste des modèles, sélectionnez celui intitulé Pas de CD-ROM puis cliquez sur le bouton Add.

Sélectionnez le menu Base on Selected Template.

Dans le champ Enter Template description saisissez le texte Avec CD-ROM réel puis cliquez sur le bouton OK.

Cliquez sur l'onglet Mounting puis sur le bouton Add.

Modifiez les options comme suit :

  • Au niveau du champ Mount Type sélectionnez CDROM de manière à monter un lecteur de CD-ROM virtuel,

  • Cliquez sur le bouton Browse de manière à accéder à une fenêtre de recherche et sélectionnez votre lecteur de CD-ROM ou de DVD-ROM dans l'arborescence qui s'affiche,

  • Si votre propre lecteur de CD-ROM ou de DVD-ROM est désigné par la lettre E sous Windows®, sélectionnez la lettre E au niveau du champ Mounted drive letter.

Dans cet exemple, le lecteur de CD-ROM virtuel E sera donc monté dans DOSBox à partir du lecteur de CD-ROM réel E de votre propre machine.

Cliquez enfin sur le bouton OK.

La liste des lecteurs virtuels doit maintenant afficher une ligne supplémentaire.

Cliquez sur le bouton OK de manière à valider le modèle en cours.

Mise en place du troisième modèle

Si ce n'est pas déjà fait, lancez Daemon Tools et faites un clic droit sur l'icône correspondante dans la barre de tâches de Windows®.

Sélectionnez le menu Virtual CD/DVD-ROM \ Set number of devices... \ 1 drive. Pour les besoins des jeux DOS®, il ne sera pas utile d'émuler plus d'un lecteur de CD-ROM virtuel à la fois.

Dans la liste sélectionnez le modèle intitulé Pas de CD-ROM puis cliquez sur le bouton Add.

Sélectionnez le menu Base on Selected Template.

Dans le champ Enter Template description saisissez le texte Avec CD-ROM virtuel (Daemon Tools) puis cliquez sur le bouton OK.

Cliquez sur l'onglet Mounting puis cliquez sur le bouton Add.

Modifiez les options comme indiqué sur la capture suivante :

  • Au niveau du champ Mount Type sélectionnez CDROM de manière à monter un lecteur de CD-ROM virtuel,

  • Cliquez sur le bouton Browse de manière à accéder à une fenêtre de recherche et sélectionnez votre lecteur de DVD-ROM virtuel dans l'arborescence qui s'affiche,

  • Si votre propre lecteur émulé est désigné par la lettre F sous Windows®, sélectionnez la lettre F au niveau du champ Mounted drive letter.

Cliquez enfin sur le bouton OK.

Le lecteur de CD-ROM virtuel F sera donc monté dans DOSBox à partir du lecteur de CD-ROM F émulé par Daemon Tools.

La liste des lecteurs virtuels doit maintenant afficher une ligne supplémentaire.

Cliquez sur le bouton OK de manière à valider le modèle en cours.


Les différentes formes de jeux DOS

Les jeux DOS® disponibles en téléchargement sur des sites d'abandonware peuvent se présenter sous différentes formes :

  • Des fichiers compressés sous forme d'archives au format ZIP, RAR, ACE, 7Z...,

  • Des fichiers images au format ISO, CUE, BIN, NRG...,

  • Des fichiers images compressés.

Les archives au format ZIP, RAR, ACE, 7Z...

Une archive au format ZIP, RAR, ACE ,7Z... est un fichier regroupant des fichiers et des dossiers dont la taille a été réduite à l'aide d'un procédé appelé compression.

Il existe de nombreux formats d'archivage dont les plus connus sont les formats ZIP, RAR, ACE et 7Z.

Une archive peut être créée à l'aide d'applications telles que WinZIP, WinRAR, WinACE, 7-Zip, IZARC... généralement désignées sous le terme d'outils de compression.

Exemple : Certaines applications assurent les tâches de compression et de décompression, d'autres uniquement de décompression : c'est le cas de XAce Plus ou UnRAR.

Pour correctement exploiter le contenu d'une archive, il est indispensable de préalablement le décompresser.

Important : Certaines versions de Windows® ou certaines applications permettent de gérer le contenu d'une archive comme s'il s'agissait d'un simple répertoire. En dépit de cela il vous faudra toujours en décompresser le contenu : n'installez, ne configurez ou n'exécutez un jeu qu'une fois l'archive décompressée dans un répertoire de votre disque dur.

La plupart des outils de compression et de décompression prenant en charge les formats les plus courants, vous ne serez pas forcé d'utiliser le logiciel avec lequel une archive a été créée.

Exemple : Pour exploiter le contenu d'une archive ZIP créée avec WinZIP, cette application n'est pas nécessaire : ce format est en effet supporté par la presque totalité des outils de compression existants.

Les fichiers images au format ISO, CUE, BIN, NRG...

Un fichier image de CD-ROM, appelé aussi image au format ISO, CUE, BIN, NRG... est le reflet exact du contenu d'un CD-ROM : à savoir sa structure et les informations qu'il contient.

Il peut-être créé à partir d'une application de gravure telle que Nero Burning ROM, Easy CD Creator, Alcohool...

Chaque application gère en outre des formats dit propriétaires qui lui sont propres : NRG pour Nero Burning ROM, GI pour Record Now !, CDR pour CDR-WIN...

Pour schématiser, un fichier image représente une "photographie" informatique du support original.

Ce format présente l'avantage d'être aisément stockable et de permettre de recréer à tout moment une copie du CD-ROM identique à l'original : pour cela vous devez cependant posséder l'une des applications mentionnées précédemment.

Important : Si vous souhaitez recréer un CD-ROM à partir d'un fichier image, assurez-vous de ne pas graver le fichier image sur le CD-ROM.

Concrètement vous ne devez pas créer un disque de données contenant le fichier image mais réaliser une opération généralement désignée sous l'intitulé Graver une image.

Le contenu du CD-ROM sera donc créé à partir du fichier image mais ce ne sera pas le fichier image.

Remarque : Sachez qu'il n'est pas toujours possible de créer l'image d'un CD-ROM pour des raisons de protection contre la copie.

Pour exploiter un fichier image, il n'est pas nécessaire de recréer un CD-ROM, il pourra en effet être monté à l'aide d'une application telle que Daemon Tools ou Alcohool.

Monter une image consiste à émuler la présence du CD-ROM original à l'aide d'une application : elle sera alors considérée comme un véritable CD-ROM par le système d'exploitation (ici Windows®).

Sachez que DOSBox assure la prise en charge des fichiers au format ISO, CUE et BIN sans le recours à une application tierce : ce point ne sera cependant pas abordé dans le cadre de ce guide de prise en main.

Remarque : Certaines applications de gravure incluent des fonctions qui leur permettent de monter des images.

Reportez-vous à la documentation technique de Daemon Tools pour déterminer la liste des formats dont il assure la prise en charge. Certains, pourtant non répertoriés, peuvent dans certains cas être gérés.

Quelques points importants

Il arrive qu'une archive contienne à son tour une ou plusieurs autres archives, auquel cas leur contenu devra lui aussi être décompressé.

Exemple : L'archive King_Arthur.zip contient le fichier Lisez-moi.txt et l'archive K_Arthur.rar. Le contenu de l'archive King_Arthur.zip doit donc d'abord être décompressé. Une fois l'opération terminée deux fichiers sont alors disponibles : Lisez-moi.txt et K_Arthur.rar. Le contenu de ce dernier devra à son tour être décompressé pour être exploitable.

Si l'archive contient un fichier image, il devra être monté ou le CD-ROM original recréé.

Le contenu d'une archive est le plus souvent :

  • La sauvegarde d'un jeu pré-installé (cliquez ici),

  • La version dite "full-CD" d'un jeu fourni à l'origine sur CD-ROM (cliquez ici),

  • Le fichier image d'un CD-ROM (cliquez ici).


Les jeux pré-installés

Les jeux pré-installés correspondent à des jeux dont la phase d'installation, voire de configuration, a déjà été réalisée sur le disque dur d'une machine.

Exemple : C'est le cas de certaines compilations parues vers la fin des années 90 et de la plupart des jeux qui peuvent être téléchargés sur des sites d'abandonware.

Commencez par copier le répertoire du jeu dans le répertoire C:\Jeux_DOS de votre machine. Si la copie est réalisée depuis un CD-ROM ou un DVD-ROM, assurez-vous ensuite que son contenu ne soit pas protégé en écriture : dans le cas contraire il ne vous sera pas possible d'effectuer de sauvegardes en cours de partie.

Si le jeu est fourni sous forme d'archive au format ZIP, RAR, ACE, 7Z... son contenu doit au préalable être décompressé.

Cliquez ici pour obtenir de plus amples informations.

Lancez D-Fend.

Cliquez ensuite sur le menu Profile \ Add/Use template ou sur l'icône [image].

Depuis la liste des modèles sélectionnez celui intitulé Pas de CD-ROM et cliquez sur le bouton Select.

Sélectionnez le menu Select for Wizard.

Renseignez à présent le profil du jeu :

  • Profil Name : Saisissez le nom que vous souhaitez donner au profil. Il est conseillé de saisir le nom du jeu pour une question de lisibilité.

  • Game EXE : Indiquez l'emplacement du fichier permettant l'exécution du jeu. Il se trouve normalement dans le répertoire du jeu et porte l'extension BAT ou EXE. Pour ce faire cliquez sur le bouton Browse.

Une fenêtre de recherche vous permet de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant l'exécution du jeu. Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Exemple : Le fichier HOF.EXE situé dans le répertoire C:\Jeux_DOS\HOF.

  • Setup EXE : Indiquez l'emplacement du fichier permettant la configuration du jeu, lequel se trouve normalement dans le répertoire du jeu. Il s'agira le plus souvent d'un fichier intitulé SETUP.EXE, CONFIG.EXE, SETSOUND.EXE, INSTALL.EXE... Pour ce faire cliquez sur le bouton Browse.

Une fenêtre de recherche vous permet de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant la configuration du jeu. Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Exemple : Le fichier SETUP.EXE situé dans le répertoire C:\Jeux_DOS\HOF.

Remarque : La sélection du fichier de configuration dans un profil n'est pas obligatoire, notamment car certains jeux ne disposent pas d'un programme de configuration séparé, celle-ci s'effectuant dans le jeu lui-même.

Dans d'autres cas le jeu est pré-configuré ou se configure de manière automatique au lancement.

Une fois le profil renseigné, cliquez sur le bouton Accept all defaults.

Le profil est maintenant ajouté à la liste.

Si nécessaire il vous reste maintenant à configurer le jeu, notamment pour permettre la gestion du son (pour les musiques ainsi que les voix et les bruitages le cas échéant).

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Setup ou sur l'icône [image] de manière à débuter la procédure de configuration.

L'élément le plus important dans la configuration d'un jeu DOS® est le son : à ce titre sachez que DOSBox s'appuie sur votre propre carte son afin d'émuler des modèles plus anciens.

Par défaut DOSBox émule les cartes sons suivantes :

  • Sound Blaster 16, laquelle offre une compatibilité descendante de type Sound Blaster Pro, Sound Blaster et Adlib,

  • Gravis UltraSound,

  • Une interface MPU-401 permettant la diffusion des musiques au format MIDI. Toutes les cartes sons disposant d'une table d'ondes proposent une émulation MPU-401 : elles offrent par conséquent une compatibilité General MIDI, General Standard, Roland Sound Canvas, et dans une moindre mesure Roland MT-32/LAPC-1.

Le plus souvent il vous sera demandé de sélectionner le modèle de carte son que vous utilisez : vous pourrez choisir l'un des modèles émulés par DOSBox.

Le nombre de modèles proposé dépend des jeux et de leur année de mise sur le marché.

Si DOSBox émule par défaut une carte son Sound Blaster 16, ce modèle ne vous sera pas toujours proposé : vous pourrez toutefois sélectionner l'un de ceux avec lesquels elle offre une compatibilité descendante.

Bien que les interfaces varient, elles restent de conception similaire d'un jeu à l'autre.

Notez que certains jeux vous permettent de sélectionner un modèle de carte son différent pour les musiques, les effets sonores et les voix.

Remarque : Si votre carte son dispose d'une table d'ondes pour la diffusion des musiques MIDI, et si le jeu vous le propose, sélectionnez General MIDI / Sound Canvas de préférence à Sound Blaster pour les musiques : le rendu obtenu sera de meilleure qualité.

Le choix Roland MT-32 / Roland LAPC-1 peut s'envisager mais donne souvent des résultats décevants sur des cartes sons standards.

Il vous sera généralement demandé de renseigner les ressources correspondantes aux modèles de cartes sons que vous avez sélectionnés.

En l'absence de ces informations, la gestion du son ne pourra pas être assurée.

Par défaut DOSBox utilise les ressources virtuelles suivantes :

 | Adresse | IRQ | DMA 8-bit | DMA 16-bit
Sound Blaster 16 | 220 | 7 | 1 | 5
Interface MPU-401 | 330 |  |  |

 | Adresse | IRQ 1 | IRQ 2 | DMA 1 | DMA 2
GUS | 240 | 5 | 5 | 3 | 3

Ces valeurs conviennent normalement à tous les jeux et il ne vous sera pas nécessaire de les modifier.

L'affichage est un paramètre sur lequel vous n'aurez généralement pas à intervenir : la majorité des jeux développés en mode réel utilisent en effet le mode VGA standard (résolution de 320x200 pixels dans une profondeur de 256 couleurs).

La sélection des modes d'affichage dans un jeu peut varier, elle s'articule autour des choix suivants :

Mode | Résolutions et profondeurs de couleurs
CGA | 320x200 en 4 couleurs 640x200 en 2 couleurs
EGA | 320x200, 640x200 et 640x350 en 16 couleurs
VGA / MCGA | 320x200 en 16 ou 256 couleurs 640x400 et 640x480 en 16 couleurs 720x480 en 16 couleurs
SVGA / VESA | 640x480, 800x600 et 1024x768 en 256 couleurs

Certains jeux ne vous offrent qu'un choix de modes graphiques restreint, dans des résolutions habituellement fixes : le plus souvent 320x200 pixels en 16 ou 256 couleurs.

D'autres vous permettent d'accéder à une panoplie de modes plus étendue.

Vous pouvez alors sélectionner, dans un mode donné, l'une des différentes résolutions prises en charge.

Une fois le jeu correctement configuré, il ne reste plus qu'à l'exécuter.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Game ou sur l'icône [image].


Les jeux fournis sur CD-ROM

Les jeux nécessitant d'être installés sur disque dur

De nombreux jeux DOS® fournis sur CD-ROM nécessitent tout d'abord d'être installés sur un disque dur de manière à être configurés et exécutés : dans le cas contraire ils ne seront pas exploitables.

Commencez par lancer D-Fend.

Cliquez ensuite sur le menu Profile \ Add/Use template ou sur l'icône [image].

Depuis la liste des modèles sélectionnez celui intitulé Avec CD-ROM réel et cliquez sur le bouton Select.

Sélectionnez le menu Select for Wizard.

Renseignez à présent le profil du jeu :

  • Profil Name : Saisissez le nom que vous souhaitez donner au profil. Il est conseillé de saisir le nom du jeu pour une question de lisibilité.

  • Game EXE : Indiquez l'emplacement du fichier permettant l'installation du jeu. Il se trouve normalement à la racine du CD-ROM et s'intitule le plus souvent INSTALL.EXE, INSTDOS.EXE, INST.EXE, INSTALL.BAT... Pour ce faire cliquez sur le bouton Browse.

Une fenêtre de recherche vous permet de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant l'installation du jeu.

Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Exemple : Le fichier INSTALL.EXE situé sur le CD-ROM E.

Cliquez enfin sur le bouton Accept all defaults.

Le profil est maintenant ajouté à la liste.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Game ou sur l'icône [image] de manière à débuter la procédure d'installation.

Il vous sera demandé de sélectionner l'emplacement dans lequel le jeu sera installé : à savoir sur quel disque et dans quel répertoire. Sélectionnez le disque C.

Bien que le choix du répertoire vous soit proposé par défaut, vous pouvez le modifier.

Remarque : En réalité le jeu sera installé sur le disque dur virtuel C de DOSBox, soit dans le répertoire C:\Jeux_DOS de votre machine.

Les noms des fichiers et des répertoires ne peuvent excéder 8 caractères sous MS-DOS®.

Sachez aussi qu'un chemin trop long pourra être refusé : C:\DUKE3D, C:\WESTWOOD\LOL constituent des exemples de chemins valides.

Pour le jeu Full Throttle le choix du lecteur et du répertoire de destination se font de manière séparée.

Il en est de même pour Lands of Lore bien que tout se fasse au sein d'une fenêtre de saisie unique.

Dans d'autres cas le lecteur et le répertoire de destination devront être spécifiés simultanément. C'est le cas de Simon the Sorcerer II ou Duke Nukem 3D.

Une fois votre choix effectué, les fichiers nécessaires sont copiés dans le répertoire du jeu, à partir duquel il sera ensuite configuré et exécuté.

Il vous reste à présent à configurer le jeu, notamment pour permettre la prise en charge du son : aussi bien pour les musiques que pour les voix et les bruitages le cas échéant. Pour certains jeux cette étape peut être facultative.

Remarque : La configuration d'un jeu n'est pas une étape obligatoire : certains jeux étant pré-configurés ou se configurant de manière automatique.

La procédure de configuration reste similaire d'un jeu à l'autre bien que l'interface utilisée puisse différer, suivant les jeux elle peut d'ailleurs être plus ou moins automatisée.

Elle s'effectue généralement à l'aide d'un fichier intitulé SETUP.EXE, CONFIG.EXE, SETSOUND.EXE ou SETSND.EXE, voire parfois INSTALL.EXE, lequel se situe normalement dans le répertoire où le jeu a été installé.

Remarque : Il arrive que le fichier utilisé soit le même que celui nécessaire à l'installation, auquel cas il est copié du CD-ROM dans le répertoire du jeu au cours de la procédure.

Notez qu'en fonction des jeux il peut porter un nom différent et qu'il n'est malheureusement pas toujours évocateur.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

  • Game EXE : Indiquez cette fois l'emplacement du fichier permettant l'exécution du jeu. Il se trouve normalement dans le répertoire du jeu et porte l'extension BAT ou EXE. Pour ce faire cliquez sur le bouton Browse situé à droite du champ.

  • Setup EXE : Indiquez l'emplacement du fichier permettant la configuration du jeu. Il se trouve normalement lui aussi dans le répertoire du jeu. Pour ce faire cliquez sur le bouton Browse situé à droite du champ.

Une fenêtre de recherche vous permet dans chaque cas de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant l'exécution et la configuration du jeu.

Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Remarque : La sélection du fichier de configuration dans un profil n'est pas obligatoire.

Si le jeu se configure une fois lancé, vous pouvez laisser le champ correspondant vide.

Une fois les sélections effectuées, cliquez sur le bouton OK.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Setup ou sur l'icône [image] de manière à débuter la procédure de configuration.

L'élément le plus important dans la configuration d'un jeu DOS® est le son : à ce titre sachez que DOSBox s'appuie sur votre propre carte son afin d'émuler des modèles plus anciens.

Par défaut DOSBox émule les cartes sons suivantes :

  • Sound Blaster 16, laquelle offre une compatibilité descendante de type Sound Blaster Pro, Sound Blaster et Adlib,

  • Gravis UltraSound,

  • Une interface MPU-401 permettant la diffusion des musiques au format MIDI. Toutes les cartes sons disposant d'une table d'ondes proposent une émulation MPU-401 : elles offrent par conséquent une compatibilité General MIDI, General Standard, Roland Sound Canvas, et dans une moindre mesure Roland MT-32/LAPC-1.

Le plus souvent il vous sera demandé de sélectionner le modèle de carte son que vous utilisez : vous pourrez choisir l'un des modèles émulés par DOSBox.

Le nombre de modèles proposé dépend des jeux et de leur année de mise sur le marché.

Si DOSBox émule par défaut une carte son Sound Blaster 16, ce modèle ne vous sera pas toujours proposé : vous pourrez toutefois sélectionner l'un de ceux avec lesquels elle offre une compatibilité descendante.

Bien que les interfaces varient, elles restent de conception similaire d'un jeu à l'autre.

Notez que certains jeux vous permettent de sélectionner un modèle de carte son différent pour les musiques, les effets sonores et les voix.

Remarque : Si votre carte son dispose d'une table d'ondes pour la diffusion des musiques MIDI, et si le jeu vous le propose, sélectionnez General MIDI / Sound Canvas de préférence à Sound Blaster pour les musiques : le rendu obtenu sera de meilleure qualité.

Le choix Roland MT-32 / Roland LAPC-1 peut s'envisager mais donne souvent des résultats décevants sur des cartes sons standards.

Il vous sera généralement demandé de renseigner les ressources correspondantes aux modèles de cartes sons que vous avez sélectionnés.

En l'absence de ces informations, la gestion du son ne pourra pas être assurée.

Par défaut DOSBox utilise les ressources virtuelles suivantes :

 | Adresse | IRQ | DMA 8-bit | DMA 16-bit
Sound Blaster 16 | 220 | 7 | 1 | 5
Interface MPU-401 | 330 |  |  |

 | Adresse | IRQ 1 | IRQ 2 | DMA 1 | DMA 2
GUS | 240 | 5 | 5 | 3 | 3

Ces valeurs conviennent normalement à tous les jeux et il ne vous sera pas nécessaire de les modifier.

L'affichage est un paramètre sur lequel vous n'aurez généralement pas à intervenir : la majorité des jeux développés en mode réel utilisent en effet le mode VGA standard (résolution de 320x200 pixels dans une profondeur de 256 couleurs).

La sélection des modes d'affichage dans un jeu peut varier, elle s'articule autour des choix suivants :

Mode | Résolutions et profondeurs de couleurs
CGA | 320x200 en 4 couleurs 640x200 en 2 couleurs
EGA | 320x200, 640x200 et 640x350 en 16 couleurs
VGA / MCGA | 320x200 en 16 ou 256 couleurs 640x400 et 640x480 en 16 couleurs 720x480 en 16 couleurs
SVGA / VESA | 640x480, 800x600 et 1024x768 en 256 couleurs

Certains jeux ne vous offrent qu'un choix de modes graphiques restreint, dans des résolutions habituellement fixes : le plus souvent 320x200 pixels en 16 ou 256 couleurs.

D'autres vous permettent d'accéder à une panoplie de modes plus étendue.

Vous pouvez alors sélectionner, dans un mode donné, l'une des différentes résolutions prises en charge.

Une fois le jeu correctement configuré, il ne reste plus qu'à l'exécuter.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Game ou sur l'icône [image].

Les jeux ne nécessitant pas d'être installés sur disque dur

Certains jeux peuvent être lancés directement depuis leur CD-ROM sans nécessiter d'installation préalable : le disque dur ne sera alors sollicité que pour réaliser des sauvegardes en cours de partie.

Important : Certains jeux fournis sur CD-ROM correspondent parfois à des versions pré-installées. Si c'est le cas reportez-vous alors au chapitre intitulé Les jeux pré-installés.

Commencez par lancer D-Fend et cliquez ensuite sur le menu Profile \ Add/Use template ou sur l'icône [image].

Depuis la liste des modèles sélectionnez celui intitulé Avec CD-ROM réel et cliquez sur le bouton Select.

Sélectionnez le menu Select for Wizard.

Renseignez à présent le profil du jeu :

  • Profil Name : Saisissez le nom que vous souhaitez donner au profil. Il est conseillé de saisir le nom du jeu pour une question de lisibilité.

  • Game EXE : Indiquez l'emplacement du fichier permettant l'exécution du jeu. Il se trouve normalement à la racine du CD-ROM virtuel et porte l'extension BAT ou EXE. Pour ce faire cliquez sur le bouton Browse situé à droite du champ.

Une fenêtre de recherche vous permet de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant l'exécution du jeu. Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Exemple : Le fichier DOTT.BAT situé sur le CD-ROM virtuel E.

Cliquez enfin sur le bouton Accept all defaults.

Le profil est maintenant ajouté à la liste, il ne vous reste plus qu'à exécuter le jeu.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Game ou sur l'icône [image].


Les fichiers images

Les jeux fournis sous forme de fichiers images correspondent à des jeux à l'origine sur CD-ROM.

Lancez Daemon Tools si ce n'est pas déjà fait.

Faites un clic droit sur l'icône correspondante dans la barre de tâches de Windows®.

Par défaut aucun fichier image n'est encore monté : pour monter celui de votre choix, sélectionnez le menu Virtual CD/DVD-ROM \ Device 0: \ Mount image.

Une fenêtre de recherche vous permet de parcourir l'arborescence de votre machine de manière à sélectionner un fichier image existant.

Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Exemple : Vous pouvez monter le fichier HAND_OF_FATE.ISO situé dans le répertoire C:\Jeux_DOS de votre machine.

Le fichier image est ensuite monté en tant que CD-ROM virtuel et accessible comme un véritable CD-ROM sous Windows®.

Effectuez la même opération si vous souhaitez monter un fichier image différent.

Remarque : En cours de jeu vous pouvez à tout moment passer d'un CD-ROM virtuel à un autre. Si vous êtes en plein écran à ce moment-là il vous suffit de passer en mode fenêtré à l'aide de la combinaison de touches Alt + Entrée.

Pour retirer un CD-ROM virtuel préalablement monté, utilisez le menu Virtual CD/DVD-ROM \ Device 0: \ Unmount image.

Le CD-ROM virtuel est alors retiré et n'est plus accessible sous Windows®, le fichier image n'est cependant pas effacé et vous pourrez le remonter ultérieurement si vous le souhaitez.

Les jeux nécessitant d'être installés sur disque dur

De nombreux jeux DOS® fournis sur CD-ROM nécessitent tout d'abord d'être installés sur un disque dur de manière à être configurés et exécutés : dans le cas contraire ils ne seront pas exploitables.

Commencez par lancer D-Fend.

Cliquez ensuite sur le menu Profile \ Add/Use template ou sur l'icône [image].

Depuis la liste des modèles sélectionnez celui intitulé Avec CD-ROM virtuel (Daemon Tools) et cliquez sur le bouton Select.

Sélectionnez le menu Select for Wizard.

Renseignez à présent le profil du jeu :

  • Profil Name : Saisissez le nom que vous souhaitez donner au profil. Il est conseillé de saisir le nom du jeu pour une question de lisibilité.

  • Game EXE : Indiquez l'emplacement du fichier permettant l'installation du jeu. Il se trouve normalement à la racine du CD-ROM et s'intitule le plus souvent INSTALL.EXE, INSTDOS.EXE, INST.EXE, INSTALL.BAT... Pour ce faire cliquez sur le bouton Browse.

Une fenêtre de recherche vous permet de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant l'installation du jeu.

Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Exemple : Le fichier INSTALL.EXE situé sur le CD-ROM virtuel F.

Cliquez enfin sur le bouton Accept all defaults.

Le profil est maintenant ajouté à la liste.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Game ou sur l'icône [image] de manière à débuter la procédure d'installation.

Il vous sera demandé de sélectionner l'emplacement dans lequel le jeu sera installé : à savoir sur quel disque et dans quel répertoire. Sélectionnez le disque C.

Bien que le choix du répertoire vous soit proposé par défaut, vous pouvez le modifier.

Remarque : En réalité le jeu sera installé sur le disque dur virtuel C de DOSBox, soit dans le répertoire C:\Jeux_DOS de votre machine.

Les noms des fichiers et des répertoires ne peuvent excéder 8 caractères sous MS-DOS®.

Sachez aussi qu'un chemin trop long pourra être refusé : C:\DUKE3D, C:\WESTWOOD\LOL constituent des exemples de chemins valides.

Pour le jeu Full Throttle le choix du lecteur et du répertoire de destination se font de manière séparée.

Il en est de même pour Lands of Lore bien que tout se fasse au sein d'une fenêtre de saisie unique.

Dans d'autres cas le lecteur et le répertoire de destination devront être spécifiés simultanément. C'est le cas de Simon the Sorcerer II ou Duke Nukem 3D.

Une fois votre choix effectué, les fichiers nécessaires sont copiés dans le répertoire du jeu, à partir duquel il sera ensuite configuré et exécuté.

Il vous reste à présent à configurer le jeu, notamment pour permettre la prise en charge du son : aussi bien pour les musiques que pour les voix et les bruitages le cas échéant. Pour certains jeux cette étape peut être facultative.

Remarque : La configuration d'un jeu n'est pas une étape obligatoire : certains jeux étant pré-configurés ou se configurant de manière automatique.

La procédure de configuration reste similaire d'un jeu à l'autre bien que l'interface utilisée puisse différer, suivant les jeux elle peut d'ailleurs être plus ou moins automatisée.

Elle s'effectue généralement à l'aide d'un fichier intitulé SETUP.EXE, CONFIG.EXE, SETSOUND.EXE ou SETSND.EXE, voire parfois INSTALL.EXE, lequel se situe normalement dans le répertoire où le jeu a été installé.

Remarque : Il arrive que le fichier utilisé soit le même que celui nécessaire à l'installation, auquel cas il est copié du CD-ROM dans le répertoire du jeu au cours de la procédure.

Notez qu'en fonction des jeux il peut porter un nom différent et qu'il n'est malheureusement pas toujours évocateur.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

  • Game EXE : Indiquez cette fois l'emplacement du fichier permettant l'exécution du jeu. Il se trouve normalement dans le répertoire du jeu et porte l'extension BAT ou EXE. Pour ce faire cliquez sur le bouton Browse situé à droite du champ.

  • Setup EXE : Indiquez l'emplacement du fichier permettant la configuration du jeu. Il se trouve normalement lui aussi dans le répertoire du jeu. Pour ce faire cliquez sur le bouton Browse situé à droite du champ.

Une fenêtre de recherche vous permet dans chaque cas de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant l'exécution et la configuration du jeu.

Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Remarque : La sélection du fichier de configuration dans un profil n'est pas obligatoire.

Si le jeu se configure une fois lancé, vous pouvez laisser le champ correspondant vide.

Une fois les sélections effectuées, cliquez sur le bouton OK.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Setup ou sur l'icône [image] de manière à débuter la procédure de configuration.

L'élément le plus important dans la configuration d'un jeu DOS® est le son : à ce titre sachez que DOSBox s'appuie sur votre propre carte son afin d'émuler des modèles plus anciens.

Par défaut DOSBox émule les cartes sons suivantes :

  • Sound Blaster 16, laquelle offre une compatibilité descendante de type Sound Blaster Pro, Sound Blaster et Adlib,

  • Gravis UltraSound,

  • Une interface MPU-401 permettant la diffusion des musiques au format MIDI. Toutes les cartes sons disposant d'une table d'ondes proposent une émulation MPU-401 : elles offrent par conséquent une compatibilité General MIDI, General Standard, Roland Sound Canvas, et dans une moindre mesure Roland MT-32/LAPC-1.

Le plus souvent il vous sera demandé de sélectionner le modèle de carte son que vous utilisez : vous pourrez choisir l'un des modèles émulés par DOSBox.

Le nombre de modèles proposé dépend des jeux et de leur année de mise sur le marché.

Si DOSBox émule par défaut une carte son Sound Blaster 16, ce modèle ne vous sera pas toujours proposé : vous pourrez toutefois sélectionner l'un de ceux avec lesquels elle offre une compatibilité descendante.

Bien que les interfaces varient, elles restent de conception similaire d'un jeu à l'autre.

Notez que certains jeux vous permettent de sélectionner un modèle de carte son différent pour les musiques, les effets sonores et les voix.

Remarque : Si votre carte son dispose d'une table d'ondes pour la diffusion des musiques MIDI, et si le jeu vous le propose, sélectionnez General MIDI / Sound Canvas de préférence à Sound Blaster pour les musiques : le rendu obtenu sera de meilleure qualité.

Le choix Roland MT-32 / Roland LAPC-1 peut s'envisager mais donne souvent des résultats décevants sur des cartes sons standards.

Il vous sera généralement demandé de renseigner les ressources correspondantes aux modèles de cartes sons que vous avez sélectionnés.

En l'absence de ces informations, la gestion du son ne pourra pas être assurée.

Par défaut DOSBox utilise les ressources virtuelles suivantes :

 | Adresse | IRQ | DMA 8-bit | DMA 16-bit
Sound Blaster 16 | 220 | 7 | 1 | 5
Interface MPU-401 | 330 |  |  |

 | Adresse | IRQ 1 | IRQ 2 | DMA 1 | DMA 2
GUS | 240 | 5 | 5 | 3 | 3

Ces valeurs conviennent normalement à tous les jeux et il ne vous sera pas nécessaire de les modifier.

L'affichage est un paramètre sur lequel vous n'aurez généralement pas à intervenir : la majorité des jeux développés en mode réel utilisent en effet le mode VGA standard (résolution de 320x200 pixels dans une profondeur de 256 couleurs).

La sélection des modes d'affichage dans un jeu peut varier, elle s'articule autour des choix suivants :

Mode | Résolutions et profondeurs de couleurs
CGA | 320x200 en 4 couleurs 640x200 en 2 couleurs
EGA | 320x200, 640x200 et 640x350 en 16 couleurs
VGA / MCGA | 320x200 en 16 ou 256 couleurs 640x400 et 640x480 en 16 couleurs 720x480 en 16 couleurs
SVGA / VESA | 640x480, 800x600 et 1024x768 en 256 couleurs

Certains jeux ne vous offrent qu'un choix de modes graphiques restreint, dans des résolutions habituellement fixes : le plus souvent 320x200 pixels en 16 ou 256 couleurs.

D'autres vous permettent d'accéder à une panoplie de modes plus étendue.

Vous pouvez alors sélectionner, dans un mode donné, l'une des différentes résolutions prises en charge.

Une fois le jeu correctement configuré, il ne reste plus qu'à l'exécuter.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Game ou sur l'icône [image].

Les jeux ne nécessitant pas d'être installés sur disque dur

Certains jeux peuvent être lancés directement depuis leur CD-ROM sans nécessiter d'installation préalable : le disque dur ne sera alors sollicité que pour réaliser des sauvegardes en cours de partie.

Important : Certains jeux fournis sur CD-ROM correspondent parfois à des versions pré-installées. Si c'est le cas reportez-vous alors au chapitre intitulé Les jeux pré-installés.

Commencez par lancer D-Fend et cliquez ensuite sur le menu Profile \ Add/Use template ou sur l'icône [image].

Depuis la liste des modèles sélectionnez celui intitulé Avec CD-ROM virtuel (Daemon Tools) et cliquez sur le bouton Select.

Sélectionnez le menu Select for Wizard.

Renseignez à présent le profil du jeu :

  • Profil Name : Saisissez le nom que vous souhaitez donner au profil. Il est conseillé de saisir le nom du jeu pour une question de lisibilité.

  • Game EXE : Indiquez l'emplacement du fichier permettant l'exécution du jeu. Il se trouve normalement à la racine du CD-ROM virtuel et porte l'extension BAT ou EXE. Pour ce faire cliquez sur le bouton Browse situé à droite du champ.

Une fenêtre de recherche vous permet de parcourir l'arborescence de votre machine de manière à sélectionner le fichier permettant l'exécution du jeu. Une fois la sélection effectuée, cliquez sur le bouton Ouvrir.

Exemple : Le fichier DOTT.BAT situé sur le CD-ROM virtuel F.

Cliquez enfin sur le bouton Accept all defaults.

Le profil est maintenant ajouté à la liste, il ne vous reste plus qu'à exécuter le jeu.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Run \ Run Game ou sur l'icône [image].


Les jeux en version full-CD

Les jeux en version full-CD comprennent l'ensemble des fichiers qui figuraient sur leur CD-ROM : par conséquent ils devront être gravés à la racine d'un nouveau CD-ROM de manière à le reconstituer.

De tels jeux peuvent être accompagnés de fichiers audio au format MP3, OGG ou WAV, lesquels correspondent aux pistes audio qui devront être gravées sur le même CD-ROM.

Une fois le CD-ROM gravé, reportez-vous au chapitre Les jeux fournis sur CD-ROM (cliquez ici).

Important : Sachez qu'il vous est possible de monter un répertoire dans DOSBox, de manière à ce qu'il soit considéré comme un véritable CD-ROM : ce point ne sera cependant pas abordé dans le cadre de ce guide d'utilisation.


Affichage

Passer en mode plein écran

Par défaut DOSBox fonctionne en mode fenêtré : utilisez la combinaison de touches Alt + Entrée pour passer en mode plein écran.

Utilisez la même combinaison pour passer d'un mode à l'autre à tout moment.

Agrandir la taille de la fenêtre en mode fenêtré

Lorsque DOSBox fonctionne en mode fenêtré, la taille de la fenêtre obtenue peut ne pas offrir un confort visuel suffisant : sa taille doit alors être modifiée au niveau du profil du jeu.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

Cliquez sur l'onglet General.

Sélectionnez le coefficient de multiplication qui sera appliqué à la taille de la fenêtre.

Avec une valeur de 1.00 la fenêtre est affichée dans sa taille originale.

Important : L'option Render method doit être définie à ddraw pour que la taille de la fenêtre puisse être modifiée.

Les coefficients inférieurs à 1.00 permettent de réduire la taille de la fenêtre.

Exemple : Un coefficient de 1.50 permet de multiplier la taille de la fenêtre par 1.50.

Forcer l'utilisation d'une résolution en mode plein écran

Lorsque DOSBox fonctionne en mode plein écran, la résolution utilisée peut-être forcée : le profil du jeu doit pour cela être modifié.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

Cliquez sur l'onglet General.

Cochez l'option Fullfixed.

Sélectionnez ensuite la résolution de votre choix dans le champ Resolution.

Important : Ne sélectionnez pas une résolution inutilement élevée, les performances du jeu pourraient s'en trouver amoindries.

Assurez-vous d'autre part qu'elle soit prise en charge par votre moniteur, pour cela consultez le guide technique qui l'accompagne.

Sélectionner une résolution inférieure à celle dans laquelle fonctionne le jeu pourra occasionner des défauts d'affichage.


Souris

Libérer le pointeur de la souris

Lorsque DOSBox fonctionne en mode fenêtré, utilisez la combinaison de touches Ctrl + F10 pour rendre le pointeur de la souris actif sous Windows® ou dans la fenêtre de DOSBox.

Remarque : Lorsque le pointeur est actif sous Windows®, cliquer sur la fenêtre du jeu suffit à le rendre actif dans DOSBox.

Ajuster la sensibilité de la souris

En fonction des jeux il est possible que les déplacements de la souris soient trop rapides, voire trop lents : il est alors nécessaire d'ajuster sa sensibilité au niveau de leur profil.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

Cliquez sur l'onglet General et sélectionnez (ou saisissez) la valeur de la sensibilité de la souris dans le champ Mouse Sensitivity :

  • Diminuez-la si les déplacements de la souris sont trop rapides,

  • Augmentez-la s'ils sont trop lents.


CD-ROM

Il se peut que certains jeux ne reconnaissent pas la présence de leur CD-ROM bien que celui-ci soit présent dans le lecteur de votre machine ou monté sous Windows® avec Daemon Tools. Pour y remédier il suffit le plus souvent d'en saisir le nom au niveau de son profil.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

Cliquez sur l'onglet Mounting.

Dans la liste des lecteurs virtuels montés dans DOSBox sélectionnez celui qui correspond au CD-ROM et cliquez sur le bouton Edit.

Dans le champ Drive label indiquez le nom du CD-ROM tel qu'il apparaît dans le Poste de travail de Windows®.

Si en dépit de cela un jeu ne reconnaît toujours pas la présence du CD-ROM, vous pouvez aussi cocher l'option Enable Input/output control si vous utilisez Windows® NT/2000/XP.

Remarque : En fonction des jeux vous pouvez avoir besoin à la fois de cocher cette option et de renseigner le nom du CD-ROM.


Son

Absence de voix, bruitages ou musiques

L'absence de son dans un jeu peut généralement avoir trois origines :

  • Le jeu n'est pas configuré ou incorrectement,

  • La version du jeu ne dispose pas de voix, bruitages ou musiques. Pour économiser de l'espace disque, certains sites sont forcés de fournir des versions tronquées de certains jeux autrement trop volumineux, comme des versions CD dépourvues de pistes audio. Il arrive aussi qu'il s'agisse de versions disquettes, moins complètes que les versions CD-ROM,

  • Le CD-ROM qui contient les voix, bruitages ou musiques n'a pas été monté dans DOSBox.

Si vous sélectionnez une carte son de type Sound Blaster 16 au niveau de la configuration d'un jeu, il arrive parfois qu'aucun son ne se fasse entendre en cours de partie. Lorsque c'est le cas, sélectionnez l'un des modèles suivants s'il vous est proposé : Sound Blaster Pro, Sound Blaster ou Adlib. Si le problème persiste sélectionner le modèle Gravis UltraSound permet parfois de le résoudre.

Son parasité ou haché

Les anomalies liées à la diffusion du son dans un jeu peuvent avoir pour origine un problème de performances : pour y remédier il vous faut alors accélérer l'émulation de DOSBox. Cliquez ici pour obtenir de plus amples informations.

Si le problème n'est pas lié aux performances, il vous faudra vraisemblablement ajuster les options liées à l'émulation des cartes sons.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

Cliquez sur l'onglet Sound :

  • Le son est parasité : vous pouvez augmenter la valeur du champ Block Size. Cela peut cependant entraîner son ralentissement. Utilisez des multiples de 512 comme 512, 1024, 2048...

  • Le son est haché : vous pouvez augmenter la valeur du champ Prebuffer. Cela peut cependant entraîner des décalages.


Performances

Au cours de l'utilisation de jeux DOS® avec DOSBox vous constaterez vraisemblablement des différences de performances : certains seront peut-être trop lents, d'autres encore trop rapides.

L'exécution d'un jeu est trop lente

La première chose à faire consiste à fermer tous les programmes qui vous sont inutiles et qui consomment peut-être une partie des ressources de votre processeur : c'est en effet lui qui prend en charge l'émulation de l'environnement fourni par DOSBox. S'il est déjà sollicité par d'autres applications, il ne pourra pas donner sa pleine mesure.

L'affichage dans un jeu se fait à l'aide d'une succession d'images, à la manière d'un film cinématographique : chaque seconde se décompose elle-même en un nombre défini d'images (framerate). C'est ce nombre qui détermine la fluidité des mouvements affichés à l'écran.

Lorsque l'exécution d'un jeu est trop lente, le défilement des images se fait donc à une vitesse moins importante, ce qui se traduit par des animations lentes et particulièrement décomposées.

La solution consiste alors à ignorer certaines images lorsqu'elles ne peuvent pas être affichées à temps (frameskip).

Si cela ne cause aucun désagrément dans le cas de plans fixes, un personnage en déplacement semblera disparaître d'un point pour réapparaître à un autre point. Si ce personnage bouge les bras, ses gestes sembleront saccadés, passant d'une position à une autre sans transition. Plus le nombre d'images ignorées au cours d'une seconde est élevé, plus ces effets seront visibles.

DOSBox permet d'ignorer jusqu'à 10 images par seconde. Pour augmenter le frameskip, utilisez la combinaison de touches Ctrl + F8. Lorsque DOSBox est exécuté en mode fenêtré, vous pouvez consulter cette valeur depuis la barre de titre de la fenêtre.

Pour réduire le frameskip, utilisez la combinaison de touches Ctrl + F7 : avec un frameskip de 0, toutes les images sont affichées.

L'utilisation du frameskip peut s'avérer utile dans le cadre de jeux utilisant des écrans fixes ou offrant une animation réduite.

Si vous souhaitez améliorer les performances d'un jeu sans le faire au détriment de sa qualité visuelle, utilisez la combinaison de touches Ctrl + F12 : elle vous permet d'accélérer l'émulation de manière progressive en augmentant les cycles de DOSBox. Sachez cependant que cette accélération nécessite en contre-partie des ressources processeurs plus importantes.

Le Gestionnaire de tâches de Windows® vous permet de connaître le taux d'occupation de votre processeur en temps réel. Sous Windows® XP et Windows® 2000 il est accessible à l'aide de la combinaison de touches Ctrl + Alt + Suppr.

Sous Windows® 95 et Windows® 98, il s'agit du Moniteur système accessible par le menu Démarrer \ Programmes \ Accessoires \ Outils systèmes \ Moniteur système. Sachez cependant qu'il n'est pas installé par défaut.

Chaque fois que vous augmentez le nombre de cycles de DOSBox, le taux d'occupation de votre processeur, donc sa charge de travail, augmente en conséquence.

Important : Si vous augmentez le nombre de cycles de manière trop importante, cela aura pour conséquence de ralentir l'émulation, voire de rendre le système instable. Pour plus de sécurité il est recommandé de ne pas dépasser un taux d'occupation de 85 %. Vous disposez ainsi d'une marge raisonnable destinée à prévenir les pointes occasionnées durant les phases plus intensives de certains jeux.

Si l'exécution d'un jeu reste encore trop lente malgré ces conseils, il se peut que votre machine ne soit pas suffisamment puissante et nécessite d'être remise à niveau. Une autre possibilité est que le jeu soit trop exigeant en ressources, même pour une machine plus puissante.

L'exécution du jeu est trop rapide

Utilisez la combinaison de touches Ctrl + F11 pour diminuer le nombre de cycles de DOSBox, ce qui aura pour conséquence de ralentir l'émulation.

La dernière possibilité consiste à utiliser un programme destiné à ralentir votre processeur tel que CPU Killer ou Mo'slo.

Optimiser le profil d'un jeu

Dès lors que vous avez déterminé les réglages les plus adaptés pour un jeu, vous pouvez modifier son profil de manière à les mémoriser.

Depuis la liste des profils sélectionnez celui du jeu et cliquez sur le menu Profile \ Edit profile ou sur l'icône [image].

Cliquez sur l'onglet Environment et sélectionnez (ou saisissez) :

  • le nombre de cycles dans le champ Cycles,

  • le nombre de sauts d'image dans le champ Frameskip.


Conseils pratiques

N'installez pas, ne configurez pas et n'exécutez pas un jeu directement depuis une archive au format ZIP, RAR, ACE, 7Z...

Cliquez ici pour obtenir de plus amples informations.

Ne configurez pas et n'exécutez pas un jeu pré-installé directement depuis un CD-ROM ou un DVD-ROM.

Dans la mesure où ce support est protégé en écriture, il vous serait alors impossible de sauvegarder en cours de partie. La seule exception étant certains jeux commerciaux qui peuvent se configurer ou s'exécuter directement depuis leur CD-ROM.

Le CD-ROM d'un jeu doit toujours être monté dans DOSBox pour être accessible.

Sachez que par défaut DOSBox ne reconnaît pas les lecteurs réels installés sur votre machine, ou virtuels montés à l'aide de Daemon Tools.


Remerciements

Je tiens à remercier :

  • Fredo_L et Zorbid, pour la confiance qu’ils m’ont toujours témoignée et leur soutien actif dans ma démarche, mais aussi pour l’accueil qu’ils m’ont réservé au sein de la communauté d’Abandonware France,

  • Victor, véritable mémoire du PC, pour son fichier de traduction de DOSBox,

  • Zorbid, Victor et Kaminari, pour leurs conseils et remarques avisés, et pour être toujours à mon écoute lorsque le besoin s’en fait sentir,

  • Zorbid et Fredo_L admins du forum Abandonware Forums, **Pouic** et **Lady** admins de feu le site The French Kiss , Lechuckcs webmaster du site Abandonware Paradise et Batrox webmaster du site Oldware pour avoir contribué à faire connaître mon travail,

  • Azur et Blood pour leur accueil et leur soutien lors de mon arrivée sur le forum Abandonware Forums,

  • Les membres du forum The French Kiss pour leur accueil, les intéressé(e)s se reconnaîtront,

  • Un grand merci à Qbix de l’équipe de développement de DOSBox pour son précieux concours dans la compréhension des modes d’émulation du processeur et des gestionnaires MIDI, ainsi que pour sa patience,

  • UBN22 pour avoir réalisé les bannières actuelles de mon site,

  • Ulf de l'équipe de développement de DOSBox, en acceptant de mettre en ligne ma première traduction du Readme.txt de la version 0.60, il a contribué sans le savoir à ce que cette aventure devienne une réalité.

Remerciements plus particuliers à toute l'équipe de développement de DOSBox pour avoir conçu et développé cette merveilleuse machine virtuelle qui, aujourd'hui, fait le bonheur de nombreux joueurs.

Et merci à toutes les personnes qui me soutiennent et qui apprécient mon travail : ce guide vous est dédié car, sans vous, il n’existerait pas.


Liens

http://dosbox.sourceforge.net - DOSBox

Le site officiel de DOSBox.

http://members.home.nl/mabus/dfend.htm - D-Fend

Le site officiel de D-Fend.

http://scummvm.sourceforge.net - ScummVM

ScummVM est un ensemble d'interpréteurs, capables d'émuler différents moteurs de jeux d'aventure, principalement des jeux Lucas Arts tels que Monkey Island ou Day of the Tentacle.

Outre une compatibilité avec les systèmes d'exploitation récents, il améliore de manière notable leur fonctionnement.

http://vogons.zetafleet.com - VOGONS

Une référence incontournable : tout ce que vous devez savoir sur la méthode pour faire fonctionner de vieux jeux sur de nouveaux systèmes.

A noter que le site s'articule autour d'un forum dont les membres s'expriment presque exclusivement en anglais.

http://clinique.jeuxvideos.free.fr - La Clinique des Jeux Vidéos

Il s'agit du site sur lequel ce guide peut être téléchargé ainsi que la version dédiée aux débutants : Débuter avec DOSBox, et celle dédiée aux utilisateurs avancés : Utilisation avancée de DOSBox.

http://www.abandonware-france.org - Lost Treasures Fr

Le site de référence pour le téléchargement de jeux abandonware en français et en anglais, assortis de nombreux articles et outils qui vous seront d'une aide précieuse pour les faire fonctionner.

A noter que le fait de télécharger certains jeux peut être considéré comme illégal par leur éditeur.

http://www.oldware.net - Oldware

Ce site retrace l’univers des jeux PC de 1979 à 1992. Il propose en téléchargement des jeux, des manuels ainsi que les outils destinés à vous aider à les faire fonctionner sur des machines récentes.

http://www.aitpast.com - Alone in the Past ?

Plongez dans le passé des jeux vidéos qui ont marqué toute une génération de joueurs.

Un site français spécialisé dans les jeux ATARI ST, AMIGA et PC agrémenté de nombreux tests, dossiers, solutions, manuels et qui vous réserve bien d'autres surprises.

http://www.abandonware-paradise.com - Abandonware Paradise

Retrouvez les plus grands classiques de l'abandonware PC et AMIGA au travers d'un site qui propose de nombreux jeux en téléchargement mais aussi des tests, des quizz et de nombreuses surprises.

http://www.lankhor.net - Lankhor.net

Le site de Fredo_L, indispensable pour celles et ceux qui souhaitent découvrir ou redécouvrir les jeux qui ont fait le succès de l'éditeur Lankhor.

La référence pour tout ce qui se rapporte de près ou de loin à l'univers de cet éditeur qui a bercé le passé de nombreux joueurs : outre des jeux à télécharger, le site vous propose des tests, des interviews et de nombreux goodies.

http://www.loriciels.org - Loriciels.org

Le site de Wille, consacré à un autre éditeur de légende : Loriciel. Plongez ou replongez dans un passé mythique au gré des nombreux jeux et des différentes rubriques qui vous sont proposés.


Diffusion et modification de ce guide

Pour l'heure la diffusion de ce guide ne peut normalement se faire que depuis le site La Clinique des Jeux Vidéos et les autres sites du réseau Abandonware France, ainsi que les sites Abandonware Paradise et Oldware.

Sa modification reste interdite sauf autorisation expresse.

Si vous souhaitez proposer ce guide sur votre site, je vous invite à prendre contact avec l'un des membres de l'équipe du réseau Abandonware France.


Contacts

Ce guide vous est avant tout destiné, aussi il se doit d'être clair, facilement compréhensible et le plus exact possible : n'hésitez donc pas à me faire part de vos suggestions, remarques, critiques, corrections ou compléments d'information.

Vous pouvez me contacter :

  • via le forum du site Abandonware Forums à l’adresse http://www.abandonware-forums.org,

  • par e-mail à l'adresse clinique.jeuxvideos@free.fr pour des questions ayant trait à ce guide d'utilisation.


Fichier image

Un fichier image, appelée aussi image au format ISO, CUE, BIN, NRG... est le reflet exact du contenu d'un CD-ROM : à savoir sa structure et les informations qu'il contient.

Il représente en quelque sorte une "photographie" informatique du support original.

Notez qu'il existe aussi des fichiers images de disquettes et de disques durs, généralement au format IMG.

Cliquez ici pour obtenir de plus amples informations.


Monter un lecteur

Monter un lecteur consiste à rendre accessible son contenu dans DOSBox. Par défaut les disques durs et autres lecteurs installés sur votre machine ne sont pas reconnus par DOSBox.

Dans DOSBox les lecteurs que vous montez sont qualifiés de lecteurs virtuels, par opposition à des lecteurs physiques réels.


Système d'exploitation

Logiciel dont le but est de permettre l'exploitation d'une machine par un utilisateur.

En l'absence de système d'exploitation, une machine ne constitue en fait qu'un assemblage de composants électroniques.

MS-DOS®, Windows® et Linux comptent parmi les systèmes d'exploitation les plus connus.